Device Compatibility

Follow

Comments

4 comments

  • Avatar
    Darren Able

    Very disappointing  that this won't  work on my Galaxy 5.  That is ridiculous.  Much of the world operates on something other than an Apple platform.

  • Avatar
    Elmer Gordner

    Any plans for a Windows 10 app?

  • Avatar
    Michael Roth

    I was hoping I could use my surface rt-no chance of that?

     

  • Avatar
    David Kennedy

    Hi Darren-- to make our Android app the best it can be for the majority of users, we made the decision to make the app only compatible with Android devices that have an operating system of 5.0 and above. I know this isn't what you wanted to hear, but you would need an Android device with a higher operating system if you wanted to run the app. Email us at help@gc.com if you have any other questions. 

Article is closed for comments.